Logo site Des Geeks et des lettres

L'application pour surveiller / sauvegarder vos smartphonesL'oeil inquisiteur de Bibispy

Activer Zend Guard Loader sur mon blog WordPress

Comment activer Zend Guard Loader sur un blog WordPress hébergé par GoDaddy ?

Cette technique, testée sur un hébergement GoDaddy, est peut-être différente sur d’autres plates-formes.

Définition

Zend Guard Loader est une application gratuite, qui s’installe sur le serveur qui héberge votre site, qui a besoin de PHP, et qui permet de décoder les applications encodées par Zend (et donc de les faire fonctionner). Il a aussi la vertu d’accélerer l’exécution du code PHP 4 et supérieur.

Guide

Tout d’abord, pour activer Zend Guard Loader, il faut que le serveur (personnel ou mutualisé) utilise PHP version 5.3. Dans le cas contraire (5.2), il faudra vous rabattre sur Zend Optimizer.

Changer la version de votre PHP

Pour connaître la version PHP que vous avez et la changer :

  1. connectez-vous sur votre Account Manager
  2. cliquez sur Web Hosting
  3. cliquez sur Launch
  4. Rendez-vous dans la section « Server » et examinez la version de votre PHP
  5. Pour en changer, rendez-vous dans le menu « More« 
  6. Sélectionnez « Programming Languages« 
  7. Sélectionnez PHP 5.3
  8. Cliquez sur « Update« 

Là il vous faudra attendre 10 minutes pour que le changement soit effectif et pouvoir continuer.

Activer php 5.3

Désactiver APC

APC est une application qui veut dire ALTERNATIVE PHP CACHE. Elle n’est pas compatible avec Zend. Si vous utilisez un serveur mutualisé comme moi, il va falloir la désactiver :

  • connectez-vous à votre Account Manager
  • cliquez sur Web Hosting
  • cliquez sur Launch
  • Dans la section Tools, cliquez sur FTP FILE MANAGER pour ouvrir votre FTP (on peut aussi utiliser Filezilla pour le faire)
  • Cherchez dans les fichiers de votre site un fichier PHP.INI ou PHP5.INI (pour moi c’était la première solution), puis éditez-le
  • Ajoutez une nouvelle ligne et tapez apc.enabled=0
  • cliquez sur Save pour sauvegarder le fichier.

Attention : pensez à enregistrer votre fichier avant d’y toucher, de manière à pouvoir le retrouver en cas de problème.

Créez un fichier PHP5.INI

Une fois que vous êtes en PHP 5.3 et que vous avez désactivé APC, toujours dans votre FTP, créez un fichier PHP5.INI s’il n’existe pas déjà (personnellement j’ai dû le créer).

Fichier php5.ini

Ouvrez donc ce fichier vierge et ajoutez-y simplement la ligne suivante :

zend_extension=/usr/local/Zend/lib/Guard-5.5.0/php-5.3.x/ZendGuardLoader.so

Attention : il faut que vous soyiez en PHP 5.3 sans quoi l’ensemble de votre site peut être corrompu. Sauvegardez toujours avant de modifier.

Trois flèches vers le bas

1- Logiciel de brouillage d’adresse IP :

Contourner la censure en surfant anonyme

2- L’article explicatif :

La différence entre un proxy et un VPN

3- Comment espionner un smartphone (app) :

L’application de référence

Commentez ici

  • Laly 31 octobre 2013, 19 07

    et comment faire pour l’installer sur un serveur mutualisé lambda ? Si quelqu’un sait, merci.
    Je cherches …

    Réponds !

Article suivant:

Article précédent:

Recherche

A vos stylos !

  • Chris: “Bonjour, Quel est le nom de la table du plugin W3Total Cache car je ne la trouve…Déc 1, 09:22
  • Greg: “Liens de l'article mis à jour.Nov 27, 14:32
  • Greg: “Vraiment pénible ce problème. Pour ma part je l'ai résolu en créant un raccourci manuel dans mes favoris et en…Nov 20, 23:28
  • Jacqueline: “Je suis sur Safari.... même problème. Mon appli pour iPad ne fonctionne pas non plus.Nov 18, 08:44
  • Greg: “Ouais mais c'est vrai que ton article était bien senti. Ca le fait que tu le lises depuis Feedly :)…Nov 3, 21:00
  • Youness: “Bonjour, Merci pour cette article il ma aider enormement lors de la creation de mom projet Ma question…Nov 3, 20:29
Share This